歌曲封面 未知作品
  • 歌曲封面再回首Mike 曾比特

网站已运行 1 年 78 天 12 小时 33 分

Powered by Typecho & Sunny

5 online · 58 ms

小野博客 小野(Hirono)博客的个人网站,主要讲述关于小野的一些陈芝麻烂谷子事。网络、生活、我的主张,也是一个自留地
Title

【易语言】系列教程--调用API接口扫码获取qqCookie和获取信息

小野

·

Article
⚠️ 本文最后更新于2024年01月31日,已经过了138天没有更新,若内容或图片失效,请留言反馈

简介

今天我们利用QQ空间API接口,进行扫码获得CK码

准备信息

请求参数

参数名称是否需要参数说明
type请求选择用get来获取二维码信息
qrsig填入get获取后的qrsig值然后将type值改为result进行获取Cookie值信息

返回参数

参数名称参数类型参数说明
codeinteger状态码
msgstring状态信息
datastring返回的Cookie

思路

打开易语言,创建一个窗口并使用一个图片组件。记住图片组件的显示方式选择缩放图片模式。

接着我们在创建一个按钮组件,用来获取“二维码”图片。

图文解

部分代码:

♾️ text 代码:
.版本 2

.子程序 _按钮1_被单击
.局部变量 json, 类_json
.局部变量 返回值, 文本型
.局部变量 二维码, 文本型
.局部变量 二维码地址, 文本型
.局部变量 转换, 字节集

返回值 = 编码_URL解码_快速 (网页_访问S (“https://api.pearktrue.cn/api/qrcode/login/kongjian.php?type=get”), 真, 真)
json.解析 (返回值)
二维码 = json.取通用属性 (“data.qrsig”)
二维码地址 = json.取通用属性 (“data.qr_code”)
转换 = 编码_Base64转图片 (二维码地址)
图片框1.图片 = 转换

运行结果:

完整版截图

完整代码

♾️ text 代码:
.版本 2
.支持库 e2ee

.程序集 窗口程序集_启动窗口
.程序集变量 二维码, 文本型

.子程序 _按钮1_被单击
.局部变量 json, 类_json
.局部变量 返回值, 文本型
.局部变量 二维码地址, 文本型
.局部变量 转换, 字节集

返回值 = 编码_URL解码_快速 (网页_访问S (“https://api.pearktrue.cn/api/qrcode/login/kongjian.php?type=get”), 真, 真)
json.解析 (返回值)
.如果真 (返回值 = “”)
    编辑框1.加入文本 (“API接口已失效或出现异常” + #换行符)
    返回 ()
.如果真结束

.如果真 (返回值 ≠ “”)
    二维码 = json.取通用属性 (“data.qrsig”)
    二维码地址 = json.取通用属性 (“data.qr_code”)
    转换 = 编码_Base64转图片 (二维码地址)
    图片框1.图片 = 转换

.如果真结束
' 输出调试 (返回值)

.子程序 _按钮2_被单击
.局部变量 json, 类_json
.局部变量 返回值, 文本型
.局部变量 状态码, 文本型
.局部变量 是否成功, 文本型
.局部变量 P_uin, 文本型
.局部变量 skey, 文本型
.局部变量 p_skey, 文本型
.局部变量 pt4_token, 文本型

.如果真 (二维码 = “”)
    编辑框1.加入文本 (“先扫二维码” + #换行符)
    返回 ()
.如果真结束
返回值 = 编码_URL解码_快速 (网页_访问S (“https://api.pearktrue.cn/api/qrcode/login/kongjian.php?type=result&qrsig=” + 二维码), 真, 真)
json.解析 (返回值)
是否成功 = json.取通用属性 (“data”)
.如果真 (是否成功 = “已经失效”)
    编辑框1.加入文本 (“二维码已经失效” + #换行符)
    返回 ()
.如果真结束


.如果真 (是否成功 = “未失效”)
    编辑框1.加入文本 (“二维码没有失效,请扫码” + #换行符)
    返回 ()
.如果真结束

.如果真 (是否成功 = “认证中”)
    编辑框1.加入文本 (“扫码成功,请确认登录” + #换行符)
    返回 ()
.如果真结束


.如果真 (寻找文本 (返回值, “已登录”, , 假) ≠ -1)
    P_uin = json.取通用属性 (“data.p_uin”)
    .如果真 (P_uin = “”)
        P_uin = “没有找到”
    .如果真结束
    skey = json.取通用属性 (“data.skey”)
    .如果真 (skey = “”)
        skey = “没有找到”
    .如果真结束
    p_skey = json.取通用属性 (“data.p_skey”)
    .如果真 (p_skey = “”)
        p_skey = “没有找到”
    .如果真结束
    pt4_token = json.取通用属性 (“data.pt4_token”)
    .如果真 (pt4_token = “”)
        pt4_token = “没有找到”
    .如果真结束

    编辑框1.加入文本 (“P_uin:” + P_uin + #换行符 + “skey:” + skey + #换行符 + “p_skey:” + p_skey + #换行符 + “pt4_token:” + pt4_token + #换行符)

.如果真结束

输出调试 (返回值)

现在已有 0 条评论,3 人点赞

广告

页底广告 页底广告
Comment
发表
搜 索 消 息 足 迹
你还不曾留言过..
你还不曾留下足迹..
博主